FedEx Web Service Outage
Incident Report for Shippo
Resolved
FedEx rate and label requests are fully operational again. We sincerely apologize for this interruption in service.
Posted Mar 22, 2017 - 16:38 PDT
Investigating
FedEx rate and label requests are failing. We're actively in contact with FedEx to resolve the situation.
Posted Mar 22, 2017 - 12:08 PDT