FedEx Degraded Performance
Incident Report for Shippo
Resolved
FedEx label requests are fully operational again.
Posted 2 months ago. Aug 07, 2017 - 11:58 PDT
Investigating
FedEx label requests have elevated error rates, we're currently investigating.
Posted 3 months ago. Aug 07, 2017 - 08:36 PDT