Degraded System Performance and Errors
Incident Report for Shippo
Resolved
We identified an issue that resulted in degraded response time. The issue has been resolved, and all systems are fully functional again.
Posted Apr 16, 2017 - 21:01 PDT
Investigating
We are investigating an issue that is causing degraded system service
Posted Apr 16, 2017 - 20:37 PDT