Delay in USPS Tracking updates

Incident Report for Shippo

Resolved

This incident has been resolved.
Posted Apr 02, 2025 - 16:47 PDT

Monitoring

Tracking events are recovering, and we are monitoring the situation.
Posted Apr 02, 2025 - 15:36 PDT

Investigating

We have detected an issue in receiving File based Tracking updates from USPS. Our team has contacted the carrier and we are monitoring the situation. During this time, tracking updates may be delayed but will be sent once the carrier’s API is restored
Posted Apr 02, 2025 - 13:47 PDT
This incident affected: Carrier API (USPS).