Canada Post Shipment service outage

Incident Report for Shippo

Resolved

This incident has been resolved.
Posted Jul 14, 2026 - 10:56 UTC

Investigating

We are experiencing some issues in Shipment service with Canada Post . We have reached out to the carrier and are actively monitoring the status of this issue. We will provide further updates soon.
Posted Jul 14, 2026 - 07:19 UTC
This incident affected: Carrier API (Canada Post).