Elevated error rate on DHL E_Commerce Transaction

Incident Report for Shippo

Resolved

This incident has been resolved.
Posted Dec 10, 2025 - 18:08 UTC

Monitoring

Carrier fixed the issue on their end service are back to operational.
Posted Dec 10, 2025 - 17:15 UTC

Investigating

We’re seeing increased error rates for the Shipment and Transaction services with DHL E-Commerce. The carrier has confirmed they are investigating this major incident. We’re actively monitoring and will share further updates soon.
Posted Dec 10, 2025 - 16:57 UTC
This incident affected: Carrier API (DHL eCommerce).