Deutsche Post Scheduled Maintenance

Scheduled for Feb 15, 06:00 - 14:00 UTC

Update

We will be undergoing scheduled maintenance during this time.
Posted Feb 11, 2026 - 09:39 UTC

Scheduled

Deutsche Post has a scheduled maintenance window on Feb 15, 2026 at 6:00 AM UTC. This will last up to 8 hours, During this time, all Deutsche Post services may be intermittently unavailable. We recommend retrying any failed requests after maintenance is complete.
Posted Feb 10, 2026 - 19:49 UTC
This scheduled maintenance affects: Carrier API (Deutsche Post).