USPS tracking outage

Incident Report for Shippo

Resolved

This incident has been resolved.
Posted Mar 16, 2026 - 12:12 UTC

Investigating

USPS tracking maintenance was completed about 2 hours ago, but we are still not receiving any tracking updates. We have reached out to USPS for clarification and will keep you posted once we receive an update.
Posted Mar 16, 2026 - 10:27 UTC
This incident affected: Carrier API (USPS).