Elevated error rate on USPS Tracking API

Incident Report for Shippo

Resolved

After investigating our Eng team determined the reported USPS tracking issue has no impact to our partners.

Resolving the incident.
Posted Sep 08, 2025 - 15:45 UTC

Investigating

We are experiencing some tracking difficulties with USPS that started around 09/07/25 01:00 AM UTC. We have reached out to the carrier and we actively monitoring the status of these issues. During this time, tracking updates may be delayed but will be sent once the carrier’s API is restored
Posted Sep 07, 2025 - 13:59 UTC
This incident affected: Carrier API (USPS).