Web App – Labels not visible in shipments tab

Incident Report for Shippo

Resolved

This incident has been resolved.
Posted Sep 18, 2026 - 03:55 UTC

Investigating

We’re seeing an issue where some users may be unable to see their labels in the Shipments tab of the Web App. Our team is actively investigating and working toward a resolution. We’ll provide another update as soon as we have more information.
Posted Sep 17, 2026 - 20:53 UTC
This incident affected: Shippo Web Dashboard.