Elevated error rate on Deutsche Post Transaction

Incident Report for Shippo

Resolved

This incident has been resolved.
Posted Jun 17, 2026 - 21:27 UTC

Identified

Deutsche Post confirmed that they are having technical issue on their end their IT team is working on the fix
Posted Jun 17, 2026 - 15:58 UTC

Update

We are continuing to investigate this issue.
Posted Jun 17, 2026 - 15:14 UTC

Investigating

We have detected an elevated error rate for the Deutsche Post transaction service. We have reached out to the carrier and actively monitoring the status of this issue and will provide further updates soon.
Posted Jun 17, 2026 - 15:08 UTC
This incident affected: Carrier API (Deutsche Post, EVRi).