Label Generation Degradation

Incident Report for Shippo

Resolved

This incident has been resolved.
Posted Sep 03, 2025 - 21:06 UTC

Investigating

We are currently seeing increased errors with label generation. We’re actively investigating and will post further updates soon
Posted Sep 03, 2025 - 19:41 UTC
This incident affected: Shippo REST API, Shippo Web Dashboard, and Shippo Platform API.