Degraded Web Dashboard Performance

Incident Report for Shippo

Resolved

This incident has been resolved.
Posted Nov 27, 2020 - 22:49 UTC

Identified

Some users may experience delayed package template assignment and rate generation for new orders.
This issue is actively being worked on, and we will post updates once available.
Posted Nov 27, 2020 - 22:23 UTC
This incident affected: Shippo Web Dashboard.