Billing Degraded Performance All Customers

Incident Report for Shippo

Resolved

This incident has been resolved.
Posted Aug 13, 2026 - 00:00 UTC

Monitoring

The problem has been addressed and the backlog is draining.
Posted Aug 12, 2026 - 21:46 UTC

Investigating

We are currently experiencing degraded invoicing performance affecting all customers. Our team is actively investigating the issue and working to restore normal service as quickly as possible.

We will provide additional updates as more information becomes available.
Posted Aug 12, 2026 - 21:37 UTC
This incident affected: Shippo Platform API.