Tracking update delay

Incident Report for Shippo

Resolved

This incident has been resolved.
Posted Jun 02, 2025 - 20:08 PDT

Investigating

We are currently experiencing up to a 2-hour delay in tracking updates. Our team is actively monitoring the situation and working to restore normal processing times
Posted Jun 02, 2025 - 16:05 PDT
This incident affected: Shippo REST API and Shippo Platform API.