Shippo platform Scheduled Maintenance

Scheduled for Sep 14, 03:00 - 04:00 UTC

Update

We will be undergoing scheduled maintenance during this time.
Posted Aug 19, 2025 - 15:49 UTC

Scheduled

Shippo platform will perform maintenance on their system on September 14, 2025 from 3 AM UTC to September 14, 2025 from 4 AM UTC

During the cited timeframe, we expect a downtime of approximately 10 minutes during which all Shippo services will be temporarily unavailable.

Affected Services:
Tracking (Tracking Status, Webhooks), Transaction (Label Purchase, Download Label), Shipments (Rates not returning, service method not returning), Rates (Incorrect Rates)

Potentially Affected Services:
Address (Validate Address, Save address)
Posted Aug 19, 2025 - 14:30 UTC
This scheduled maintenance affects: Shippo REST API, Shippo Web Dashboard, and Shippo Platform API.