USPS First Class International Labels Issue

Incident Report for Shippo

Resolved

This issue has been resolved.
Posted May 28, 2020 - 19:32 UTC

Monitoring

The issue has been fixed and we are monitoring the results.
Posted May 28, 2020 - 18:55 UTC

Identified

The issue has been identified, and we are working with USPS to implement a fix. We will continue to provide updates as we have them.
Posted May 27, 2020 - 04:17 UTC

Investigating

We are experiencing an issue with USPS First Class International label generation. We are actively working with USPS to resolve. We will provide updates as we have them.
Posted May 26, 2020 - 21:39 UTC
This incident affected: Carrier API (USPS).