USPS Tracking disruption

Incident Report for Shippo

Resolved

We have started receiving tracking updates from USPS again. Service has returned to normal, and the issue has been resolved.
Posted Mar 18, 2026 - 05:09 UTC

Investigating

We are experiencing an interruption in USPS tracking events from the carrier. Our team has reached out to USPS and is actively monitoring the situation. We keep you updated as soon as we receive reply from the carrier.
Posted Mar 18, 2026 - 01:53 UTC
This incident affected: Carrier API (USPS).