Elevated error rate on Better trucks & Veho Shipment Service

Incident Report for Shippo

Resolved

This incident has been resolved.
Posted Jun 09, 2025 - 15:45 PDT

Investigating

We have detected an elevated error rate from Better trucks & Veho Shipment API. Our team has actively investigating this issue.
Posted Jun 09, 2025 - 15:03 PDT
This incident affected: Carrier API (Better Trucks, Veho).