Elevated error rate on FedEx Transaction

Incident Report for Shippo

Resolved

This incident has been resolved.
Posted Nov 14, 2025 - 05:19 UTC

Investigating

We are experiencing some issues on transaction service with FedEx . We have reached out to the carrier and and actively monitoring the status of these issues and will provide further updates soon.
Posted Nov 14, 2025 - 04:38 UTC
This incident affected: Carrier API (FedEx, EVRi).