Delay in Tracking Updates Across All Carriers

Incident Report for Shippo

Resolved

This incident has been resolved.
Posted May 22, 2025 - 22:45 PDT

Update

The issue has been resolved and all tracking statuses are being updated and should be fully recovered by 10:30 PM PT.
Posted May 22, 2025 - 18:42 PDT

Monitoring

A fix has been deployed and we are monitoring the results
Posted May 22, 2025 - 17:43 PDT

Identified

We’ve identified the cause, and our team is actively working on a fix
Posted May 22, 2025 - 17:34 PDT

Investigating

We are currently seeing a decrease in tracking updates impacting all carriers. We are actively investigating and will post further updates soon
Posted May 22, 2025 - 17:19 PDT
This incident affected: Shippo REST API, Shippo Web Dashboard, and Shippo Platform API.