DHL Express Label Failures for Canada – Temporary Service Suspension

Incident Report for Shippo

Resolved

DHL Express resumed service to Canada starting June 30
Posted Jul 02, 2025 - 18:49 UTC

Identified

DHL Express will temporarily suspend shipments to and from Canada starting June 20
Beginning Tuesday, June 17 at 6 pm PT, DHL Express will stop collecting shipments to and from Canada and will temporarily suspend shipping operations in Canada starting on Friday, June 20.

Please note that if you attempt to purchase a DHL Express label for shipments to/from Canada after June 17 at 6 pm PT, the transaction will fail.
We offer alternative carrier options–such as USPS and UPS–to keep your shipments moving.
Posted Jun 17, 2025 - 23:13 UTC
This incident affected: Carrier API (DHL Express).