Shippo Scheduled Maintenance

Scheduled for Mar 22, 07:00 - 08:00 UTC

Update

We will be undergoing scheduled maintenance during this time.
Posted Mar 09, 2026 - 17:54 UTC

Scheduled

On March 22 from 12:00 AM PST – 1:00 AM PST (07:00 UTC – 08:00 UTC), the Shippo team will be performing optimizations on our critical services. During this maintenance window, customers may experience up to 10 minutes of service disruption and up to a 24-hour delay in reporting.
In the event this maintenance needs to be rescheduled, the backup date will be March 28.
Posted Mar 09, 2026 - 17:51 UTC
This scheduled maintenance affects: Shippo REST API, Shippo Web Dashboard, and Shippo Platform API.