USPS Tracking disruption

Incident Report for Shippo

Resolved

This incident has been resolved.
Posted Mar 31, 2026 - 07:46 UTC

Investigating

We are currently experiencing an interruption in USPS tracking events, which appears to be due to a carrier-side issue. USPS is actively investigating the problem.

We have reached out to them for an ETA and are closely monitoring the situation. We will keep you informed as soon as we have further updates.
Posted Mar 31, 2026 - 02:27 UTC
This incident affected: Carrier API (USPS).