As of 7:00 PM UTC, the issue causing our service disruption has been fully resolved. All systems are operating normally. Our engineering team identified and corrected the root cause, and continue to monitor closely. A RCA will be published once our internal review is complete. We appreciate your patience and apologize for the disruption.
Posted Aug 14, 2025 - 19:52 UTC
Identified
Between 18:34 and 19:12 UTC, customers may have experienced delays or failures when attempting to create shipping labels. The issue was caused by a spike in database CPU usage, triggered by inefficient queries on a recently modified internal table related to shipment insurance. The relevant database index was missing, which led to significant performance degradation. We have taken corrective action and restored the missing index. Label creation has returned to normal performance. We are auditing related schema changes and improving safeguards to prevent this issue from recurring.
Posted Aug 14, 2025 - 19:02 UTC
This incident affected: Shippo REST API, Shippo Web Dashboard, and Shippo Platform API.