Issue affecting USPS International Labels

Incident Report for Shippo

Resolved

This incident has been resolved.
Posted Jul 15, 2025 - 00:46 UTC

Investigating

We are currently experiencing an issue with USPS International label purchases with Shippo's account, resulting in failed requests due to token authorization errors. We are actively monitoring the issue and are in contact with the carrier to work toward a resolution.
Posted Jul 14, 2025 - 22:34 UTC
This incident affected: Shippo REST API, Shippo Web Dashboard, Shippo Platform API and Carrier API (USPS).