Royal mail store feeder Tracking Maintenance

Scheduled for Apr 25, 21:30 UTC  -  Apr 26, 04:00 UTC

Update

We will be undergoing scheduled maintenance during this time.
Posted Apr 15, 2026 - 14:49 UTC

Scheduled

Royal mail storefeeder has a scheduled maintenance window on Apr 25, 2026, at 21:30 UTC. This will last up to 6 hours and 30 minutes.

During this time, tracking information will be intermittently unavailable. We recommend retrying any failed requests after maintenance is complete.
Posted Apr 15, 2026 - 14:45 UTC
This scheduled maintenance affects: Carrier API (Royal Mail (Storefeeder)).