Elevated error rate on DPD UK Transaction

Incident Report for Shippo

Resolved

This incident has been resolved.
Posted Sep 22, 2025 - 18:57 UTC

Investigating

We are experiencing some issues DPD UK Transaction. We have reached out to the carrier and are actively monitoring the status of these issues. We will provide further updates soon.
Posted Sep 22, 2025 - 15:12 UTC
This incident affected: Carrier API (DPD UK).