Delays in fulfillment to e-commerce stores
Incident Report for Shippo
Resolved
This incident has been resolved.
Posted Mar 09, 2022 - 10:15 PST
Investigating
We have identified an issue which caused delays posting the fulfillment information back to e-commerce stores connected to Shippo. This issue has been addressed and we are actively recovering.
Posted Mar 09, 2022 - 08:58 PST
This incident affected: Shippo Web Dashboard.