Elevated error rate on USPS Tracking

Incident Report for Shippo

Resolved

This incident has been resolved.
Posted Oct 17, 2025 - 03:33 UTC

Investigating

We are experiencing an interruption in USPS tracking events from the carrier. Our team has reached out to USPS and is actively monitoring the situation. We will provide further updates as soon as they become available.
Posted Oct 17, 2025 - 02:08 UTC
This incident affected: Carrier API (USPS).