Elevated error rate on RoyalMail SF Tracking

Incident Report for Shippo

Resolved

This incident has been resolved.
Posted Mar 09, 2025 - 07:21 PDT

Investigating

We are currently investigating this issue.
Posted Mar 09, 2025 - 05:09 PDT
This incident affected: Carrier API (Royal Mail (Storefeeder)).