Orders page not loading on Shippo Web Dashboard
Incident Report for Shippo
Resolved
The reported issue has been resolved.
Posted Dec 15, 2023 - 11:23 PST
Identified
We are currently investigating reports that certain customers may see a blank screen when attempting to view the Orders page. A fix has been identified.
Posted Dec 15, 2023 - 10:00 PST
This incident affected: Shippo Web Dashboard.