Deutsche Post Tracking Service Issue

Incident Report for Shippo

Resolved

This incident has been resolved.
Posted Jun 30, 2026 - 00:44 UTC

Investigating

We are experiencing elevated error rate on Deutsche Post Tracking service. We have reached out to the carrier and actively monitoring the status of this issue and will keep you posted on this.
Posted Jun 29, 2026 - 22:01 UTC
This incident affected: Carrier API (Deutsche Post).