Elevated error in USPS Manifest generation

Incident Report for Shippo

Resolved

The issue has been resolved, and the service is now operational.
Posted Sep 22, 2026 - 10:03 UTC

Monitoring

USPS has deployed a fix and the service has started recovering. We are continuing to monitor and will share any further updates.
Posted Sep 22, 2026 - 09:16 UTC

Investigating

We are currently observing an elevated error rate affecting USPS Manifest generation. Label generation is not impacted. We have reached out to USPS and are actively monitoring the situation. We will provide a further update as soon as we receive from the carrier.
Posted Sep 22, 2026 - 07:39 UTC
This incident affected: Carrier API (USPS).