USPS tracking Outage

Incident Report for Shippo

Resolved

USPS confirmed that they have fixed the issue from their end. The tracking service is back to operational
Posted Jul 03, 2024 - 07:55 UTC

Investigating

We are seeing Elevated error rates on tracking, Our team is actively working with carrier for more updates
Posted Jul 03, 2024 - 06:16 UTC
This incident affected: Carrier API (USPS).