Elevated error rate on Royal Mail (SF) Tracking

Incident Report for Shippo

Resolved

This incident has been resolved.
Posted Jun 15, 2025 - 00:00 PDT

Investigating

Royal Mail SF is performing maintenance on their Parcel Collect APIs from Saturday 14th June 22:00 – Sunday 15th June 03:15 UTC
During this time, transactions containing collections requests will fail.
Posted Jun 14, 2025 - 18:07 PDT
This incident affected: Carrier API (Royal Mail (Storefeeder)).