FedEx Ground domestic and international Label failures.

Incident Report for Shippo

Resolved

This incident has been resolved.
Posted Jul 24, 2024 - 23:48 UTC

Investigating

We have detected FedEx Ground domestic and international Label failures. Our team is working on this, and we are monitoring the situation.
Posted Jul 24, 2024 - 23:18 UTC
This incident affected: Carrier API (FedEx).