Elevated error rate on DHL eCommerce Transaction

Incident Report for Shippo

Resolved

This incident has been resolved.
Posted Mar 20, 2025 - 21:06 PDT

Investigating

We have detected an elevated error rate from DHL eCommerce Transaction API. Our team has contacted the carrier and we are monitoring the situation.
Posted Mar 20, 2025 - 20:27 PDT
This incident affected: Carrier API (DHL eCommerce).