Elevated error rate on FedEx affects tracking and address validation

Incident Report for Shippo

Resolved

This incident has been resolved.
Posted Jul 14, 2025 - 17:44 UTC

Monitoring

FedEx OAuth API has recovered. Both FedEx tracking and address validation services are operational. We will continue to monitor the incident.
Posted Jul 14, 2025 - 16:50 UTC

Update

We are continuing to work with FedEx for this issue.
Posted Jul 14, 2025 - 16:30 UTC

Identified

We have detected an elevated error rate from FedEx OAuth API around July 14th 15:30 UTC. This affects our tracking and address validation services. Our team has contacted the carrier and we are monitoring the situation.
Posted Jul 14, 2025 - 15:45 UTC
This incident affected: Carrier API (FedEx).