Elevated error rate on USPS international/military/US territories transactions

Incident Report for Shippo

Resolved

USPS deployed a fix on their network resolved the issue
Posted Aug 05, 2024 - 18:56 PDT

Investigating

We have written a follow-up email to the carrier in response to the growing error rate and are expecting a response.
Posted Jul 25, 2024 - 06:18 PDT

Monitoring

We are monitoring this service.
Posted Jul 24, 2024 - 22:15 PDT

Investigating

We have detected an elevated error rate from USPS's transactions API for labels going to international/military/US territories addresses. Our team has contacted the carrier, and we are monitoring the situation.
Posted Jul 24, 2024 - 10:39 PDT
This incident affected: Carrier API (USPS).