UPS Account Registration Degradation

Incident Report for Shippo

Resolved

This incident has been resolved.
Posted Sep 28, 2025 - 14:20 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 28, 2025 - 05:42 UTC

Investigating

UPS is currently experiencing degradation for account registration around 9:30 pm PT. This is causing intermittent errors during account registration during this time. We have escalated this issue to the carrier.
Posted Sep 28, 2025 - 05:08 UTC
This incident affected: Carrier API (UPS).