Elevated error rate USPS Manifest generation

Incident Report for Shippo

Update

The USPS team has deployed a fix and the service has started recovering. We’re closely monitoring the service and will keep posted with further updates.
Posted Sep 16, 2026 - 08:48 UTC

Monitoring

The USPS team has deployed a fix and the service has started recovering. We’re closely monitoring the service and will keep posted with further updates.
Posted Sep 16, 2026 - 08:47 UTC

Investigating

Hi team, we’re currently seeing an elevated error rate affecting USPS Manifest generation. We've reached out to carrier and working to resolve it. We’ll keep you posted with further updates.
Posted Sep 16, 2026 - 04:25 UTC
This incident affects: Carrier API (USPS).