Degraded Service Performance

Incident Report for Shippo

Resolved

This incident has been resolved.
Posted Aug 04, 2023 - 15:17 PDT

Monitoring

We are back to a stable state and will continue to monitor.
Posted Aug 04, 2023 - 12:39 PDT

Identified

We have identified the issue to be elevated load on our database(s) and are working to decrease and distribute load accordingly to bring it back to a stable state.
Posted Aug 04, 2023 - 12:33 PDT

Update

We are continuing to investigate this issue.
Posted Aug 04, 2023 - 12:27 PDT

Investigating

We are investigating reports of degraded performance affecting the Shippo service.
Posted Aug 04, 2023 - 12:22 PDT
This incident affected: Shippo REST API, Shippo Web Dashboard, and Shippo Platform API.