Degraded performance for UPS in tracking

Incident Report for Shippo

Resolved

This incident has been resolved.
Posted May 29, 2024 - 23:14 UTC

Monitoring

Service appears to be back to normal levels. We are monitoring this service.
Posted May 29, 2024 - 04:21 UTC

Update

We are continuing to investigate this issue.
Posted May 29, 2024 - 00:25 UTC

Investigating

We are currently investigating this issue.
Posted May 28, 2024 - 23:02 UTC
This incident affected: Carrier API (UPS).