Elevated Error Rates
Incident Report for Shippo
Resolved
The issue causing elevated error rates for label creation has been addressed.
Posted Sep 14, 2017 - 12:47 PDT
Investigating
We are investigating an issue that is causing elevated error rates for label creation.
Posted Sep 14, 2017 - 12:17 PDT