Intermittent USPS API Outage on multiple API

Incident Report for Shippo

Resolved

This incident has been resolved.
Posted Apr 02, 2026 - 20:19 UTC

Update

USPS integration is currently degraded. Customers using standalone tracking may experience delayed tracking updates, and international label generation is also degraded.
We are actively monitoring the issue and will keep you posted with any further updates.
Posted Apr 02, 2026 - 19:50 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 02, 2026 - 19:46 UTC

Update

We are continuing to investigate this issue.
Posted Apr 02, 2026 - 19:18 UTC

Investigating

We are currently experiencing issues with USPS affecting multiple USPS APIs. USPS has acknowledged the issue and their support teams are actively investigating.

We are closely monitoring the situation and will provide updates as soon as more information becomes available.
Posted Apr 02, 2026 - 19:09 UTC
This incident affected: Carrier API (USPS).