USPS File Tracking Data Loss
Incident Report for Shippo
Resolved
The USPS Tracking outage has been resolved. We are proactively working to resolve any potential gaps in tracking data. We expect immediate resolution and no disruption in operations.
Posted Mar 21, 2024 - 22:26 PDT
Investigating
An anomaly has been detected with USPS tracking data. The team is investigating the issue.
Posted Mar 21, 2024 - 21:10 PDT
This incident affected: Carrier APIs (USPS).