USPS intermittent Outage impacting V3 Label generation

Incident Report for Shippo

Resolved

This incident has been resolved.
Posted Sep 17, 2026 - 07:58 UTC

Investigating

USPS has reported an intermittent outage impacting their label generation API . Their support team is currently investigating. We are monitoring the issue and will provide an update as soon as USPS shares further information
Posted Sep 17, 2026 - 04:48 UTC
This incident affected: Carrier API (USPS).