Degraded Web Dashboard Performance
Incident Report for Shippo
Resolved
This incident has been resolved.
Posted Apr 20, 2023 - 18:21 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 20, 2023 - 18:11 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 20, 2023 - 18:02 PDT
Investigating
We are investigating reports of degraded performance affecting the Shippo web dashboard. Getting rates for international shipments are currently affected.
Posted Apr 20, 2023 - 17:21 PDT
This incident affected: Shippo Web Dashboard.