Deutsche Post label purchase failure

Incident Report for Shippo

Resolved

This incident has been resolved.
Posted Jun 02, 2026 - 17:42 UTC

Investigating

Customers using Deutsche Post through Shippo may experience intermittent issues with label purchases, shipment creation, and tracking services. The issue originates upstream with Deutsche Post's API. Other Shippo services and carriers are not affected. We are actively working with Deutsche Post to investigate the issue and will provide updates as more information becomes available.
Posted Jun 02, 2026 - 14:11 UTC
This incident affected: Carrier API (Deutsche Post).